Posts by admin.

VLAN Trunking in FreeBSD 6

Configure your switch to trunk (802.1q) desired VLANs on port connected to rl0 on FreeBSD box.

/etc/rc.conf:
ifconfig_rl0=”up”
cloned_interfaces=”vlan5 vlan6″
ifconfig_vlan5=”inet 192.168.5.254 netmask 255.255.255.0 vlan 5 vlandev rl0″
ifconfig_vlan6=”inet 192.168.6.254 netmask 255.255.255.0 vlan 6 vlandev rl0″

vlan5 and vlan6 interfaces will show up:

vlan5: flags=8843 mtu 1500
inet 192.168.5.254 netmask 0xffffff00 broadcast 192.168.5.255
ether 00:11:XX:XX:XX:XX
media: Ethernet autoselect (100baseTX )
status: active
vlan: 5 parent interface: rl0

vlan6: flags=8843 mtu 1500
inet 192.168.6.254 netmask 0xffffff00 broadcast 192.168.6.255
ether 00:11:XX:XX:XX:XX
media: Ethernet autoselect (100baseTX )
status: active
vlan: 6 parent interface: rl0

Xcode Tools 2.4

Just upgraded to Xcode Tools 2.4.


$ gcc -v
Using built-in specs.
Target: i686-apple-darwin8
Configured with: /private/var/tmp/gcc/gcc-5363.obj~28/src/configure --disable-checking -enable-werror --prefix=/usr --mandir=/share/man --enable-languages=c,objc,c++,obj-c++ --program-transform-name=/^[cg][^.-]*$/s/$/-4.0/ --with-gxx-include-dir=/include/c++/4.0.0 --with-slibdir=/usr/lib --build=powerpc-apple-darwin8 --with-arch=nocona --with-tune=generic --program-prefix= --host=i686-apple-darwin8 --target=i686-apple-darwin8
Thread model: posix
gcc version 4.0.1 (Apple Computer, Inc. build 5363)


$ gcc-3.3 -v
Using built-in specs.
Thread model: posix
gcc version 3.3 20030304 (Apple Computer, Inc. build 1819)

Cisco PPPoE client

Quick mini-howto configure PPPoE client on Cisco IOS.

interface Ethernet0/1
no ip address
pppoe enable
pppoe-client dial-pool-number 1

interface Dialer1
mtu 1492
ip address negotiated
ip nat outside
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
ppp pap sent-username USERNAME password PASSWORD
ppp ipcp dns request

Ethernet0/1 = interface to PPPoE provider
USERNAME, PASSWORD = your assigned PPPoE username and password

Tested with RDS FTTH, at least with

C2600 Software (C2600-C-M), Version 12.3(19)

Check with show pppoe session, show interface dialer 1.

Do not forget about default route (and NAT if applicable).

Mac OS X 10.4.7 on my iMac

About This Mac


iMac:~$ uname -a
Darwin iMac.local 8.7.1 Darwin Kernel Version 8.7.1: Wed Jun 7 16:19:56 PDT 2006; root:xnu-792.9.72.obj~2/RELEASE_I386 i386 i386

Cisco nat commands for iChat video conferencing

Ethernet0/1 = outside (public) interface
192.168.0.5 = mac running iChat
tested at least with IOS (tm) C2600 Software (C2600-IO3-M), Version 12.1(27b), RELEASE SOFTWARE (fc1)


ip nat inside source static udp 192.168.0.5 5060 interface Ethernet0/1 5060
ip nat inside source static udp 192.168.0.5 5190 interface Ethernet0/1 5190
ip nat inside source static tcp 192.168.0.5 5190 interface Ethernet0/1 5190
ip nat inside source static udp 192.168.0.5 5297 interface Ethernet0/1 5297
ip nat inside source static tcp 192.168.0.5 5297 interface Ethernet0/1 5297
ip nat inside source static udp 192.168.0.5 5298 interface Ethernet0/1 5298
ip nat inside source static tcp 192.168.0.5 5298 interface Ethernet0/1 5298
ip nat inside source static udp 192.168.0.5 5353 interface Ethernet0/1 5353
ip nat inside source static udp 192.168.0.5 5678 interface Ethernet0/1 5678
ip nat inside source static udp 192.168.0.5 16384 interface Ethernet0/1 16384
ip nat inside source static udp 192.168.0.5 16385 interface Ethernet0/1 16385
ip nat inside source static udp 192.168.0.5 16386 interface Ethernet0/1 16386
ip nat inside source static udp 192.168.0.5 16387 interface Ethernet0/1 16387
ip nat inside source static udp 192.168.0.5 16388 interface Ethernet0/1 16388
ip nat inside source static udp 192.168.0.5 16389 interface Ethernet0/1 16389
ip nat inside source static udp 192.168.0.5 16390 interface Ethernet0/1 16390
ip nat inside source static udp 192.168.0.5 16391 interface Ethernet0/1 16391
ip nat inside source static udp 192.168.0.5 16392 interface Ethernet0/1 16392
ip nat inside source static udp 192.168.0.5 16393 interface Ethernet0/1 16393
ip nat inside source static udp 192.168.0.5 16394 interface Ethernet0/1 16394
ip nat inside source static udp 192.168.0.5 16395 interface Ethernet0/1 16395
ip nat inside source static udp 192.168.0.5 16396 interface Ethernet0/1 16396
ip nat inside source static udp 192.168.0.5 16397 interface Ethernet0/1 16397
ip nat inside source static udp 192.168.0.5 16398 interface Ethernet0/1 16398
ip nat inside source static udp 192.168.0.5 16399 interface Ethernet0/1 16399
ip nat inside source static udp 192.168.0.5 16400 interface Ethernet0/1 16400
ip nat inside source static udp 192.168.0.5 16401 interface Ethernet0/1 16401
ip nat inside source static udp 192.168.0.5 16402 interface Ethernet0/1 16402
ip nat inside source static udp 192.168.0.5 16403 interface Ethernet0/1 16403

Syntax for Huawei routers:
interface Ethernet0/1
ip address GLOBAL_IP GLOBAL_NETMASK
nat outbound ...
nat server protocol udp global GLOBAL_IP 5060 inside 192.168.0.5 5060
nat server protocol ...

SiI 3112 and linux

2.6.16.16 with CONFIG_BLK_DEV_SIIMAGE=y and CONFIG_SCSI_SATA_SIL=y

ata2: translated ATA stat/err 0x51/04 to SCSI SK/ASC/ASCQ 0xb/00/00
ata2: status=0x51 { DriveReady SeekComplete Error }
ata2: error=0x04 { DriveStatusError }
ata2: no sense translation for status: 0x51
ata2: translated ATA stat/err 0x51/00 to SCSI SK/ASC/ASCQ 0x3/11/04
ata2: status=0x51 { DriveReady SeekComplete Error }
ata2: no sense translation for status: 0x51
ata2: translated ATA stat/err 0x51/00 to SCSI SK/ASC/ASCQ 0x3/11/04
ata2: status=0x51 { DriveReady SeekComplete Error }
ata2: no sense translation for status: 0x51
ata2: translated ATA stat/err 0x51/00 to SCSI SK/ASC/ASCQ 0x3/11/04
ata2: status=0x51 { DriveReady SeekComplete Error }
ata2: no sense translation for status: 0x51
ata2: translated ATA stat/err 0x51/00 to SCSI SK/ASC/ASCQ 0x3/11/04
ata2: status=0x51 { DriveReady SeekComplete Error }
ata2: no sense translation for status: 0x51
ata2: translated ATA stat/err 0x51/00 to SCSI SK/ASC/ASCQ 0x3/11/04
ata2: status=0x51 { DriveReady SeekComplete Error }
ata2: no sense translation for status: 0x51
ata2: translated ATA stat/err 0x51/00 to SCSI SK/ASC/ASCQ 0x3/11/04
ata2: status=0x51 { DriveReady SeekComplete Error }

dmesg:

libata version 1.20 loaded.
sata_sil 0000:00:0c.0: version 0.9
ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 11
PCI: setting IRQ 11 as level-triggered
ACPI: PCI Interrupt 0000:00:0c.0[A] -> Link [LNKD] -> GSI 11 (level, low) -> IRQ
 11
ata1: SATA max UDMA/100 cmd 0xD0802080 ctl 0xD080208A bmdma 0xD0802000 irq 11
ata2: SATA max UDMA/100 cmd 0xD08020C0 ctl 0xD08020CA bmdma 0xD0802008 irq 11
ata1: SATA link up 1.5 Gbps (SStatus 113)
ata1: dev 0 cfg 49:2f00 82:746b 83:7f01 84:4023 85:7469 86:3c01 87:4023 88:407f
ata1: dev 0 ATA-7, max UDMA/133, 488397168 sectors: LBA48
ata1: dev 0 configured for UDMA/100
scsi0 : sata_sil
ata2: SATA link up 1.5 Gbps (SStatus 113)
ata2: dev 0 cfg 49:2f00 82:746b 83:7f01 84:4023 85:7469 86:3e01 87:4023 88:407f
ata2: dev 0 ATA-7, max UDMA/133, 488397168 sectors: LBA48
ata2: dev 0 configured for UDMA/100
scsi1 : sata_sil
  Vendor: ATA       Model: WDC WD2500KS-00M  Rev: 02.0
  Type:   Direct-Access                      ANSI SCSI revision: 05
  Vendor: ATA       Model: WDC WD2500JS-55N  Rev: 10.0
  Type:   Direct-Access                      ANSI SCSI revision: 05
SCSI device sda: 488397168 512-byte hdwr sectors (250059 MB)
sda: Write Protect is off
sda: Mode Sense: 00 3a 00 00
SCSI device sda: drive cache: write back
SCSI device sda: 488397168 512-byte hdwr sectors (250059 MB)
sda: Write Protect is off
sda: Mode Sense: 00 3a 00 00
SCSI device sda: drive cache: write back
 sda: sda1
sd 0:0:0:0: Attached scsi disk sda
SCSI device sdb: 488397168 512-byte hdwr sectors (250059 MB)
sdb: Write Protect is off
sdb: Mode Sense: 00 3a 00 00
SCSI device sdb: drive cache: write back
SCSI device sdb: 488397168 512-byte hdwr sectors (250059 MB)
sdb: Write Protect is off
sdb: Mode Sense: 00 3a 00 00
SCSI device sdb: drive cache: write back
 sdb: sdb1
sd 1:0:0:0: Attached scsi disk sdb

OpenWRT on Asus WL-HDD2.5

dmesg:

CPU revision is: 00024000
Enabling BCM4710A0 cache workarounds.
Primary instruction cache 8kB, physically tagged, 2-way, linesize 16 bytes.
Primary data cache 4kB, 2-way, linesize 16 bytes.
Linux version 2.4.30 (nbd@ux-2y02) (gcc version 3.4.4 (OpenWrt-1.0)) #1 Sun Mar 26 19:02:04 CEST 2006
Setting the PFC value as 0x15
Determined physical RAM map:
 memory: 01000000 @ 00000000 (usable)
On node 0 totalpages: 4096
zone(0): 4096 pages.
zone(1): 0 pages.
zone(2): 0 pages.
Kernel command line: root=/dev/mtdblock2 rootfstype=squashfs,jffs2 init=/etc/preinit noinitrd console=ttyS0,115200
CPU: BCM4710 rev 0 at 125 MHz
Using 62.400 MHz high precision timer.
!unable to setup serial console!
Calibrating delay loop... 82.94 BogoMIPS
Memory: 14268k/16384k available (1412k kernel code, 2116k reserved, 100k data, 80k init, 0k highmem)
Dentry cache hash table entries: 2048 (order: 2, 16384 bytes)
Inode cache hash table entries: 1024 (order: 1, 8192 bytes)
Mount cache hash table entries: 512 (order: 0, 4096 bytes)
Buffer cache hash table entries: 1024 (order: 0, 4096 bytes)
Page-cache hash table entries: 4096 (order: 2, 16384 bytes)
Checking for 'wait' instruction...  unavailable.
POSIX conformance testing by UNIFIX
PCI: Fixing up bus 0
PCI: Fixing up bridge
PCI: Setting latency timer of device 01:00.0 to 64
PCI: Fixing up bus 1
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
Starting kswapd
devfs: v1.12c (20020818) Richard Gooch ([email protected])
devfs: boot_options: 0x1
JFFS2 version 2.1. (C) 2001 Red Hat, Inc., designed by Axis Communications AB.
Squashfs 2.1-r2 (released 2004/12/15) (C) 2002-2004 Phillip Lougher
pty: 256 Unix98 ptys configured
Serial driver version 5.05c (2001-07-08) with MANY_PORTS SHARE_IRQ SERIAL_PCI enabled
b44.c:v0.93 (Mar, 2004)
PCI: Setting latency timer of device 00:02.0 to 64
eth0: Broadcom 47xx 10/100BaseT Ethernet 00:11:2f:7d:85:4a
PCI: Setting latency timer of device 00:08.0 to 64
eth1: Broadcom 47xx 10/100BaseT Ethernet 00:11:2f:7d:85:4a
 Amd/Fujitsu Extended Query Table v1.1 at 0x0040
Physically mapped flash: Swapping erase regions for broken CFI table.
number of CFI chips: 1
cfi_cmdset_0002: Disabling fast programming due to code brokenness.
Flash device: 0x400000 at 0x1fc00000
Creating 5 MTD partitions on "Physically mapped flash":
0x00000000-0x00040000 : "pmon"
0x00040000-0x003f0000 : "linux"
0x000bc400-0x002b1000 : "rootfs"
mtd: partition "rootfs" doesn't start on an erase block boundary -- force read-only
0x003f0000-0x00400000 : "nvram"
0x002c0000-0x003f0000 : "OpenWrt"
Initializing Cryptographic API
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 512 buckets, 4Kbytes
TCP: Hash tables configured (established 1024 bind 2048)
ip_conntrack version 2.1 (5953 buckets, 5953 max) - 328 bytes per conntrack
ip_tables: (C) 2000-2002 Netfilter core team
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
NET4: Ethernet Bridge 008 for NET4.0
802.1Q VLAN Support v1.8 Ben Greear 
All bugs added by David S. Miller 
VFS: Mounted root (squashfs filesystem) readonly.
Mounted devfs on /dev
Freeing unused kernel memory: 80k freed
Warning: unable to open an initial console.
Algorithmics/MIPS FPU Emulator v1.5
diag boardtype: 0000041a
Probing device eth0: No Robo switch in managed mode found
Probing device eth1: No Robo switch in managed mode found
Probing device eth2: No such device
Probing device eth3: No such device
BFL_ENETADM not set in boardflags. Use force=1 to ignore.
b44: eth1: Link is up at 100 Mbps, full duplex.
b44: eth1: Flow control is off for TX and off for RX.
jffs2.bbc: SIZE compression mode activated.
PCI: Setting latency timer of device 01:02.0 to 64
PCI: Enabling device 01:02.0 (0004 -> 0006)
eth2: Broadcom BCM4320 802.11 Wireless Controller 3.90.37.0
Universal TUN/TAP device driver 1.5 (C)1999-2002 Maxim Krasnyansky
Probing device eth0: No Robo switch in managed mode found
Probing device eth1: No Robo switch in managed mode found
Probing device eth2: [switch-robo.c:90] SIOCGETCPHYRD failed!
[switch-robo.c:90] SIOCGETCPHYRD failed!
No Robo switch in managed mode found
Probing device eth3: No such device
BFL_ENETADM not set in boardflags. Use force=1 to ignore.
device eth0 entered promiscuous mode
device eth1 entered promiscuous mode
device eth2 entered promiscuous mode
eth2: attempt to add interface with same source address.
br0: port 2(eth2) entering listening state
br0: port 1(eth1) entering listening state
br0: port 2(eth2) entering learning state
br0: port 1(eth1) entering learning state
br0: port 2(eth2) entering forwarding state
br0: topology change detected, propagating
br0: port 1(eth1) entering forwarding state
br0: topology change detected, propagating
br0: port 1(eth1) entering disabled state
b44: eth1: Link is up at 100 Mbps, full duplex.
b44: eth1: Flow control is off for TX and off for RX.
br0: port 1(eth1) entering listening state
br0: port 1(eth1) entering learning state
br0: port 1(eth1) entering forwarding state
br0: topology change detected, propagating

nvram:

size: 2870 bytes (29898 left)
acc_num=0
autofw_port0=
boardnum=asusX
boardtype=bcm94710dev
boot_wait=on
clkfreq=125
console_loglevel=1
dev_status=5
dhcp_domain=wan
dhcp_enable=1
dhcp_end=192.168.1.150
dhcp_start=192.168.1.100
dhcp_wins=wan
dl_ram_addr=a0001000
dmz_ipaddr=
et0macaddr=00:11:2F:7D:85:4A
et0mdcport=0
et0phyaddr=0
et1macaddr=00:11:2F:7D:85:4A
et1mdcport=1
et1phyaddr=01
filter_client0=
filter_maclist=
filter_macmode=deny
forward_port0=
fsckpart=
fw_disable=0
hardware_version=WL300-02-03-01-20
http_lanport=80
http_passwd=admin
http_username=
http_wanport=
ide_device=105a:
isformat=0
lan_domain=
lan_hwaddr=
lan_hwnames=
lan_ifname=br0
lan_ifnames=eth1 eth2
lan_ipaddr=192.168.1.220
lan_lease=86400
lan_netmask=255.255.255.0
lan_proto=static
lan_proto_x=1
lan_stp=1
lan_wins=
log_ipaddr=
log_level=0
ntp_server=192.5.41.40 192.5.41.41 133.100.9.2
os_date=Aug  4 2004
os_flash_addr=bfc40000
os_name=linux
os_ram_addr=80001000
os_server=
os_version=3.31.12.0
password=admin
pmon_ver=PMON 3.11.19.0
productid=WLHDD
regulation_domain=0X30DE
rescueflag=disable
restore_defaults=0
restore_defaults=0
router_disable=1
scratch=a0180000
sdram_config=0x0000
sdram_init=0x0419
sdram_ncdl=0x00000000
sdram_refresh=0x8040
sh_name=
sh_num=0
sh_path=
sh_rright=
sh_rright_x=
sh_wright=
sh_wright_x=
shutdown_hit=0
st_ftp_mode=1
st_max_user=6
st_model_t=
st_name=WL-HDD
st_part1=
st_part2=
st_part3=
st_part4=
st_part_t=
st_partall=
st_samba_mode=1
st_samba_workgroup=mygroup
st_status_t=No HDD mounted
stats_server=
time_zone=UCT0
timer_interval=3600
upnp_enable=0
usb_available=1
usb_tmp_index=1:(null):add
username=admin
wan_desc=
wan_device=vlan1
wan_dns=
wan_domain=
wan_gateway=0.0.0.0
wan_hostname=
wan_hwaddr=
wan_hwname=
wan_ifname=eth1
wan_ifnames=
wan_ipaddr=0.0.0.0
wan_lease=86400
wan_netmask=0.0.0.0
wan_pppoe_ac=
wan_pppoe_demand=0
wan_pppoe_idletime=60
wan_pppoe_ifname=
wan_pppoe_keepalive=0
wan_pppoe_mru=1492
wan_pppoe_mtu=1492
wan_pppoe_passwd=
wan_pppoe_service=
wan_pppoe_username=
wan_primary=0
wan_proto=dhcp
wan_route=
wan_unit=0
wan_wins=
watchdog=3000
wl0_ifname=eth2
wl0_infra=1
wl0_mode=ap
wl0_radio=1
wl0_ssid=OpenWrt
wl_antdiv=-1
wl_auth=0
wl_auth_mode=disabled
wl_authmode_x=0
wl_bcn=100
wl_channel=0
wl_closed=0
wl_corerev=
wl_country=
wl_dtim=3
wl_frag=2346
wl_frameburst=off
wl_frameburst_x=0
wl_gmode=1
wl_gmode_protection=auto
wl_hwaddr=
wl_ifname=
wl_infra=1
wl_key1=
wl_key2=
wl_key3=
wl_key4=
wl_key=1
wl_lazywds=0
wl_maclist=
wl_maclist_num_x=0
wl_macmode=disabled
wl_macmode_x=0
wl_mode=ap
wl_phytype=b
wl_phytypes=
wl_plcphdr=long
wl_radio=1
wl_radioids=
wl_radius_ipaddr=
wl_radius_key=
wl_radius_port=1812
wl_rate=0
wl_rateset=default
wl_rateset_x=1
wl_rts=2347
wl_ssid=WL-HDD
wl_unit=0
wl_wds=
wl_wds_num_x=0
wl_wdsapply_x=1
wl_wdsmode_x=0
wl_wep=off
wl_weptype_x=0
wl_wpa_gtk_rekey=0
wl_wpa_psk=
wlp_beap_x=1
wlp_clientmode_x=1
wlp_num=0
wlp_pref_x=99

Problems with SiI 3112 SATA RAID controller

ata2: no sense translation for status: 0x51
ata2: translated ATA stat/err 0x51/00 to SCSI SK/ASC/ASCQ 0x3/11/04
ata2: status=0x51 { DriveReady SeekComplete Error }
ata2: no sense translation for status: 0x51
ata2: translated ATA stat/err 0x51/00 to SCSI SK/ASC/ASCQ 0x3/11/04
ata2: status=0x51 { DriveReady SeekComplete Error }

2.4.33-pre3 kernel, CONFIG_SCSI_SATA_SIL driver, EIO DM-8301R SATA RAID card:

libata version 1.20 loaded.
PCI(00:0c.0): version 0.9
ata1: SATA max UDMA/100 cmd 0xD080C080 ctl 0xD080C08A bmdma 0xD080C000 irq 11
ata2: SATA max UDMA/100 cmd 0xD080C0C0 ctl 0xD080C0CA bmdma 0xD080C008 irq 11
ata1: dev 0 cfg 49:2f00 82:746b 83:7f01 84:4023 85:7469 86:3c01 87:4023 88:407f
ata1: dev 0 ATA-7, max UDMA/133, 488397168 sectors: LBA48
ata1: dev 0 configured for UDMA/100
ata2: dev 0 cfg 49:2f00 82:746b 83:7f01 84:4023 85:7469 86:3e01 87:4023 88:407f
ata2: dev 0 ATA-7, max UDMA/133, 488397168 sectors: LBA48
ata2: dev 0 configured for UDMA/100
scsi0 : sata_sil
scsi1 : sata_sil
  Vendor: ATA       Model: WDC WD2500KS-00M  Rev: 02.0
  Type:   Direct-Access                      ANSI SCSI revision: 05
  Vendor: ATA       Model: WDC WD2500JS-55N  Rev: 10.0
  Type:   Direct-Access                      ANSI SCSI revision: 05
Attached scsi disk sda at scsi0, channel 0, id 0, lun 0
Attached scsi disk sdb at scsi1, channel 0, id 0, lun 0

Partial solution to DMA/write errors – BIOS upgrade:

http://www.siliconimage.com/search/searchresults.aspx?keyword=3112+bios

(4.2.76 at the time of writing)

gcc (Xcode Tools 2.2.1)

$ gcc -v
Using built-in specs.
Target: i686-apple-darwin8
Configured with: /private/var/tmp/gcc/gcc-5250.obj~12/src/configure --disable-checking -enable-werror --prefix=/usr --mandir=/share/man --enable-languages=c,objc,c++,obj-c++ --program-transform-name=/^[cg][^.-]*$/s/$/-4.0/ --with-gxx-include-dir=/include/c++/4.0.0 --build=powerpc-apple-darwin8 --with-arch=pentium-m --with-tune=prescott --program-prefix= --host=i686-apple-darwin8 --target=i686-apple-darwin8
Thread model: posix
gcc version 4.0.1 (Apple Computer, Inc. build 5250)
$ gcc-3.3 -v
Using built-in specs.
Thread model: posix
gcc version 3.3 20030304 (Apple Computer, Inc. build 1819)
$ gcc_select
Current default compiler:
gcc version 4.0.1 (Apple Computer, Inc. build 5250)

iMac dmesg

hi mem tramps at 0xffe00000
PAE enabled
standard timeslicing quantum is 10000 us
vm_page_bootstrap: 254581 free pages
mig_table_max_displ = 71
Enabling XMM register save/restore and SSE/SSE2 opcodes
83 prelinked modules
ACPI CA 20051117 [debug level=0 layer=0]
AppleACPICPU: ProcessorApicId=0 LocalApicId=0 Enabled
AppleACPICPU: ProcessorApicId=1 LocalApicId=1 Enabled
Copyright (c) 1982, 1986, 1989, 1991, 1993
        The Regents of the University of California. All rights reserved.

using 2613 buffer headers and 2613 cluster IO buffer headers
Enabling XMM register save/restore and SSE/SSE2 opcodes
IOAPIC: Version 0x20 Vectors 0:23
Started CPU 01
ACPI: System State [S0 S3 S4 S5] (S3)
Security auditing service present
BSM auditing present
disabled
rooting via boot-uuid from /chosen: 30976105-460C-4B94-B147-3EC4709F4856
Waiting on IOProviderClassIOResourcesIOResourceMatchboot-uuid-media
FireWire (OHCI) Lucent ID 5811 PCI now active, GUID 001451fffeb88896; max speed s400.
Got boot device = IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/SATA@1F,2/AppleAHCI/AppleAHCIPort@2/IOAHCIDevice@0/AppleAHCIDiskDriver/IOAHCIBlockStorageDevice/IOBlockStorageDriver/WDC WD2500JS-40NG
B2 Media/IOGUIDPartitionScheme/Merged_Untitled@2
BSD root: disk0s2, major 14, minor 2
CSRHIDTransitionDriver::probe:
CSRHIDTransitionDriver::start before command
CSRHIDTransitionDriver::stop
IOBluetoothHCIController::start Idle Timer Stopped
Jettisoning kernel linker.
Resetting IOCatalogue.
Matching service count = 0
Matching service count = 0
Matching service count = 0
Matching service count = 0
Matching service count = 0
Previous Shutdown Cause: 0
IPv6 packet filtering initialized, default to accept, logging disabled
yukonosx: Ethernet address 00:16:cb:85:c7:01
AirPortPCI_MM: Ethernet address 00:14:51:e6:7e:ae
[HCIController][setupHardware] AFH Is Supported
AppleYukon - en0 link active, 100-Mbit, full duplex, symmetric flow control enabled
(52: SystemStarter)tfp: failed on 0:
(52: SystemStarter)tfp: failed on 0:
(52: SystemStarter)tfp: failed on 0:
(52: SystemStarter)tfp: failed on 0:
(52: SystemStarter)tfp: failed on 0:
(52: SystemStarter)tfp: failed on 0:
(52: SystemStarter)tfp: failed on 0:
ATY,Wormy: vram [80000000:08000000]
ATY,Wormy: vram [80000000:08000000]
(49: coreservicesd)tfp: failed on 0:
(49: coreservicesd)tfp: failed on 0:
IOBluetoothHCIController::terminateWL .. done
USBF:   5940.663        IOUSBPipe[0x27aa740]:ClosePipe for address 2, ep 1 had a retain count > 1.  Leaking a pipe
CSRHIDTransitionDriver::probe:
CSRHIDTransitionDriver::start before command
USBF:   5942.442        IOUSBDevice[0x2bdee00]::GetFullConfigurationDescriptor - Error (e00002ed) getting first 9 bytes of config descriptor
CSRHIDTransitionDriver::stop
IOBluetoothHCIController::start Idle Timer Stopped
[HCIController][setupHardware] AFH Is Supported